Pages: 1
Whenever I try to launch an RPG Maker 2003 game I get this error. This error only appears when launching finished games and demos that automatically go into full screen mode.

If I'm test playing a game (so it comes up in the 640x480 window) then there are no problems, if I try to go from test playing into full screen I get the exact same error.

Some of the games I want to play are "locked" (I can't open them in RPG Maker 2003) so I can't just launch them in test play mode.

I'm using Windows 7 Ultimate, my graphics card is an NVidia GeForce 9500 GT, my resolution is 1768x992 and I'm using a HDMI cable.

Is there anything I can change with regards to system settings or alternatively, anything I can add to RPG_RT.ini to make the games launch in Windowed mode?

Myself and Asalieri (Tellahasa) were looking to do a collab video on RM2k3 games, I thn came across this issue.

EDIT: A somewhat long-winded solution so far has been to create a Shortcut to RPG_RT.exe, then right click, select Properties, and on the end of the Target line (where it shows the location of the original RPG_RT.exe for the game) add "NormalPlay ShowTitle Window" at the end.
This probably happens because the low resultion is not supported at your system... You could try an alternative video card driver...

You can also use AnotherFullscreenMode, a tool of mine which uses a different way of playing in fullscreen mode (without changing the screen resolution).

Put the content of this archive in the folder of the game you want to play:
...together with this file:

And then start afm_game_starter.exe. You can use F6 to toggle fullscreen (DO NOT use F4 or F5 or Alt+Enter!) and F8 to change the filter (none -> Scale2x -> hq2x)

The filter feature will make the graphics "nicer", but it's a matter of personal flavor.
I got this error when trying to run rm2k/3 games fullscreen while using crossfire. disabling crossfire solved my problem
Cherry, how and why do you always have something awesome up your sleeve?
Because I am as I am.

Sorry, there is no explaniation... although people regularely ask me similar questions (including "where/how did you learn <insert some skill here>?!"), and I never know an answer.

Well, in this case it's just that many problems come up and again and again... and if that happens often enough, I will try to create a solution. And if I have one, I can give it to others when the problem arises again. As simple as that. :)
Can't say fairer than that! Thanks again =)
i am having same problem, for trying to download those links, the first one doesn't work, and because i'm as stupid as i am, i have no idea what crossfire is. Could someone perhaps aid me?
I tried to use afm for Yume Nikki, but it didn't work. I might have been doing something wrong, could you help me figure this out please?
As this problem is likely to be increasingly common as time goes on, this is what I found.

None of the compatibility settings actually worked. Period. From research, I found that Windows 8 discontinued DirectDraw without offering a real replacement (really stupid idea, guys). They say you can use Direct2D but there doesn't seem to be an understandable way of just downloading and it sounded like some of the stuff had issues. And OpenGL is garbage.

So what to do? When I found in windowed mode rather than fullscreen, it didn't seem to want to kill the screen, and in fact was able to run. Patch this, or use DynRPG to run in auto-patch. It runs, but rather sluggish. To make things run like before: Windows XP 3, Run as Admin, and if it still seems choppy, run in 8-bit color (since it uses 256 color anyway).

Pages: 1