RMN V4.3 BUGS

Posts

Sooz
They told me I was mad when I said I was going to create a spidertable. Who’s laughing now!!!
5177
author=Addit
Yeah...I was wondering what the heck was going on a few days ago when I tried checking RMN on my phone using Chrome and I had the exact same warning message.

Well…whatever it was…it’s gone now.


Still goin on for me. Whatever, if an extra click is the price I must pay for making stupid posts, I will gladly lay down my clickin' finger in pursuit of forcing people to look at whatever terrible thoughts wandered into my head.
kentona
I am tired of Earth. These people. I am tired of being caught in the tangle of their lives.
20742
Something to do with SSL certificates, but that is beyond my understanding. I despise niddly server config. It's so finicky and I suck at it. Might have to bring in the big guns, ankylo
Sooz
They told me I was mad when I said I was going to create a spidertable. Who’s laughing now!!!
5177
We didn't have these problems back in the days of tin cans and string!
Just happened to me while replying to mail. I'm not sure what the issue is but I'll take a look.

edit: aaaand it happened while writing this post. Seems to be a Chrome issue: https://pedrogomes.medium.com/the-information-youre-about-to-submit-is-not-secure-16322d6bece9

edit #2: seems to be related to our use of a reverse proxy (the django app runs in Apache but the site is proxied through nginx). Looks like the site I posted has a fix for django. I'll give that a try.
Try now?

edit: nope
now?

edit: seems to be fixed! I wonder what I broke by fixing that...
Sooz
They told me I was mad when I said I was going to create a spidertable. Who’s laughing now!!!
5177
Let's try from my end...

Hooray! Chrome trusts RMN again!

Thank you for your hard work, ankylo!
kentona
I am tired of Earth. These people. I am tired of being caught in the tangle of their lives.
20742
author=ankylo
now?

edit: seems to be fixed! I wonder what I broke by fixing that...

Nice!

and honestly who knows??
I found a bug, but I'm not sure what's causing it. I updated my game page and it seems to revert back to the old one. I also checked on another browser to make sure it's not loading a cached version. When I went to edit the game profile again, the updated information is missing so I'm assuming it's something on the back end of RMN.
Hm... what did you edit? Did you make sure to hit submit? and wait for it to finish loading before doing something else with that tab?
author=Liberty
Hm... what did you edit? Did you make sure to hit submit? and wait for it to finish loading before doing something else with that tab?

I added an image to Pure Heart's game page. I know for a fact that it successfully submitted because I checked the page afterwards and the image still was in my locker but the game page reverted back to before I edited it. I also updated my blog so maybe that has something to do with it?
The image is showing up just fine for me. It may be that you need to hard refresh (Shift+F5) the page before it shows up.
It shows up now because I fixed it. I updated the game page on both itch.io and RMN earlier during the day. Then on RMN during the night, the medal image was gone and the description reverted back to the original.
Hi! I'm a new member and the post editor kept deleting the last line of my post. I must have edited it 5 times but there was nothing I could do to get it to stay. EDIT: it even deleted the last line of this post. FWIW I'm using Safari 14.1 on macOS 11.3. There also seems to be nothing I can do to upload a PFP. I've pasted in a couple imgure links for the same 150x150 image, but nothing I can do gets it to stay.


Extra line bc this one will probably get deleted






and another just to be safe
That is incredibly weird. Could you try using a different browser to see if it is an issue that persists outside of Safari?

As for the PFP - have you made sure that the link ends in .png or .gif or whatever file type you're using? I know that imgur defaults to a non-file end on the link, so that might be the problem. Instead of using imgur for hosting your PFP, try using your locker here (You can find it by hovering over your name in the top-left corner and clicking on Locker, then following the prompts there.)
Marrend
Guardian of the Description Thread
20053
It's completely random that I checked it today, but, it seems the link for Pic of the Moment is returning an error page? I'm pretty sure a similar issue was brought to this thread before, and also I'm pretty sure it was fixed at one point?
author=Marrend
It's completely random that I checked it today, but, it seems the link for Pic of the Moment is returning an error page? I'm pretty sure a similar issue was brought to this thread before, and also I'm pretty sure it was fixed at one point?


This appears to be a data issue. An image was deleted and the site doesn't really like that. I'll take a look to see if I can make it more robust.