Pages: 1
First and foremost, I will say this; Rpg maker VX ace was not doing this a week ago. Now suddenly, on all of my projects, the game ignores all passability for the base level, and only notices things on the second level and above. I have the left corner set to star and my character cannot move at all. Setting it to O of course let's him walk everywhere, including walls that are clearly marked with a X.

Can any one help me with this apparent glitch, or do I need to just do a fresh re-install?
I'd really like to get rid of LockeZ. His play style is way too unpredictable. He's always like this too. If he ran a country, he'd just kill and imprison people at random until crime stopped.
In multiple projects? That's actually impressive.

That's definitely something that's controlled by the scripts, so reinstalling RPG Maker would make no difference.

You could try this script, which isn't really for the same problem you're having, but might override whatever else is causing the problem:
# VXAce Star Passability Bug Fix
#   by NeonBlack
# -- Level: Easy, Normal
# -- Requires: n/a
# -- This simply checks if the tile is a star before checking passability.  
# If the tile is a star and it is passable, it then checks the tile UNDER it.  
# If not, it returns falseas always. This prevents everything that is a star 
# tile from being passable.
# -- Original Topic:
# [url]http://forums.rpgmakerweb.com/index.php?/topic/7625-vxace-passabilities-bug/[/url]

class Game_Map

  def check_passage(x, y, bit)
        all_tiles(x, y).each do |tile_id|
          flag = tileset.flags[tile_id]
          if flag & 0x10 != 0                       # [☆]: No effect on passage
                next             if flag & bit == 0 # [○] : Passable but star
                return false if flag & bit == bit   # [×] : Impassable
                return true  if flag & bit == 0  # [○] : Passable
                return false if flag & bit == bit   # [×] : Impassable
        return false                                              # Impassable
Well, Locke your script, in conjunction with me changing every floor transparent tile has worked. It seems strange that it was working like this on the complete transparent tile, but creating anouther transparent tile different from the default located one has fixed it.

It does not address why that one tile is now completely acting different from any other tile, but hey, the fix works, so I can't complain too much.
Pages: 1