@GreatRedSpirit: Will probably do that whenever I can. Right now it seems to be acting fine...though that's right now. If it acts up tomorrow, I'll follow your advice for sure (I can access notepad/notepad+ documents in Safe Mode right? Because gonna copy/paste what you said into Notepad+)

@Pianotm: The last time I cleaned it was a few months back.

Here's what I see recur the most in Administrative Logs:

For Errors:

"The following boot-start or system-start driver(s) failed to load:

This one appears with various things:

"The entry <C:\USERS\CHUCK\APPDATA\LOCAL\SKYPE\APPS\LOGIN\LANGUAGES> in the hash map cannot be updated.

Context: Application, SystemIndex Catalog

A device attached to the system is not functioning. (0x8007001f)"

For Warnings:

"InitializePrintProvider failed for provider win32spl.dll. This can occur because of system instability or a lack of system resources."

EDIT - Here's a screenshot of the Device Manager, if that matters.

Yeah, you can still use notepad in safe mode. If you do safe mode with networking you can still use the internet too! I wonder what's causing the error to even mention RAIDDisk since there's no controller for it. Still see if there's a RAID option in the BIOS and try to update your motherboard drivers, especially the SATA drivers.
Well, don't have to worry about that computer anymore as buddy of mine gave me one of his old ones (which is a million times better. Windows 7, quad-core processor, 8 GB Ram...just overall good. Only downside is it has 111 GB on the HD, but we took out the old HD from the previous computer and put it in here so it's all good). Just having issues now getting mic/headset to work (it worked the first time, but now it won't recognize the mic being in at all...don't know what the problem here is).
Alright, still having problems with this mic. It's plugged in, but it states it's not plugged in. I don't know what's going on heeeeeere. I've tried disabling all Nvidia sound things and leaving only Realtek there, but that didn't do anything. I've tried to plug in the mic into all other ports (it's a pink wire, should it SHOULD be in the pink slot for MIC...but it doesn't work there), but it doesn't recognize it being plugged in (unless in blue port, which makes it Line-in but that doesn't seem like it should be that). First time me and bud tested this headset with the mic, I was able to speak into mic and get the volume bar to move in the Sound settings thing. Anyone have any idea what could be wrong or what to do? We did a fresh install of Windows 7 on this computer and alot of things got updated so...
The TM is for Totally Magical.
On my sound card, it's the green component.
Anyone have any idea what could be wrong?
Oh! Oh! Oh! I got this one! The mic doesn't work! See? I pay attention! :P

And my mic/headset is USB and I just plug it into the port on top of my computer, so I'm about as useful as a rotten turnip.

Oh, and have fun with all of those Automatic Updates. When I did my fresh install of Windows a few weeks ago, it was sending me like 400 updates at a time. After like three days of that shit, I just turned off Automatic Updates. XD
The TM is for Totally Magical.
Thank you, Don Rickles.
So, I resolved it by uninstalling and reinstalling Realtek Audio HD Driver. I'm guessing that somehow the Windows Update messed with that driver and made it not function as it should. So everything is perfectly fine on this computer now! Windows 7 (original had Vista), quad-core (original had dual core), 111 GB HD (resolved by having my other HD from the original computer in here, so +400 GB which will be used primarily for video recording), 8 GB RAM (original had 3 GB RAM)...this thing is a beast lol.

The only thing left to resolve for me is this RPG Maker issue where it doesn't seem to want to take my David Patch (I want to have more than 99,999 HP on my enemies/bosses darnit! .V.).
Ok, so since I've had this new computer now for a couple weeks, I've had 3 issues: 2 bluescreens, both of which were Memory_Management (dunno how, the RAM has more than enough space unless it's somehow going bad), and one instance of the computer just outright shutting itself off. Any ideas what these could be?
The TM is for Totally Magical.
Power supply could be going out, not a terribly expensive problem.. Also, the processor could be overheating. Had both of those problems at one time or another. Processor might not have enough goop on it. May want to try installing a freon cooler on it. Yes, this can also cause memory errors. With a new power supply, you'd be surprised how much better your computer runs. Your systems are designed to run at certain specifications, a process commonly known as clocking. The motherboard takes care of all of this, but if she's not getting enough power, she can't do her job properly. If the processor is overheating, it can do all kinds of goofy things, but this is usually a precursor to your computer becoming a paperweight. Your problem sounds more like the power supply, though. I'll detail a processor problem.

My first computer build, I didn't install the cooling fan properly. She ran for about six months, but she would reset and turn off at the slightest provocation. Touching the tower was a no-no, and it was constantly going off at inconvenient times. My wife thought it was an annoying safety feature in the motherboard. One day, it wouldn't turn back on. The processor went out and fried the motherboard and an expensive graphics card. The rest wasn't damaged. It could have been worse. It could have fried the hard drive. Thankfully it's fine, and even now is in use in my current computer.

If you take it to someone, I'm pretty sure you'll discover that much of this is a hardware issue, not that power supplies are hard to install; you just need to plug into your disk drives and hard drives and you have a long plug for the motherboard and a tiny one that goes by the processor. There could be more going on with the memory, but no anti-virus program is perfect and viruses slip through, usually non-malicious stuff, but all of it is harmful. Your computer can also create viruses through configuration errors, which occur when programs aren't communicating with each other the way they're supposed to. Anti-virus software often doesn't catch these, quite often because it contributes to the problem.

When I installed my new power supply, the blue screen stopped, and so did the computer shutting down.

It's possible its the CPU, mobo (depending on what generation your CPU is, the CPU took the role of northbridge and memory management a few generations back), or even the PSU if your computers is requesting more power than it can supply. Cheap / Budget PSUs usually can't deliver at their promised load (and can even catastrophically fail) or undercut amperage on the 12V line and make up the marketing number on the 5.5V line, but the mobo, CPU, and graphics card all draw from the 12V rails.

What are you doing when you get these failures? If you want to check your CPU temperature you can download HW Info and it can show the monitoring your mobo does on its temperatures. If the CPU temperature gets too high it will turn itself off to protect itself. If your temperatures are high taking your computer outside and taking off the side panel of the case and blowing compressed air in there can get all kinds of dust out which can help temperatures. Determining if its your PSU is harder, but if your computer failures coincide with the computer doing work (where hardware moved out of idle, steps up, and draws more power) then that could be the case.

Processor might not have enough goop on it

I'm assuming goop is thermal paste which you shouldn't have much on. Thermal paste doesn't have great thermal conductivity compared to raw copper which is what most heat transfer tubes are made out of, including those in a CPU heatsink. The goal of the thermal paste is to fill in the micro fissures on the contact between the CPU and heatsink because that's where air sits and air has awful thermal conductivity. Applying too much thermal paste will get it in the way instead of filling in the gaps (and also too much creates a small amount of capacitance which also negatively impacts thermal conductivity).
@GreatRedSpirit: Well, both times it bluescreened, I was just browsing Firefox and talking to a friend on Skype. CPU Usage was at like 30% or less (it rarely ever goes above 30% now).
Does it happen when you play any 3d games at all or anything that would make the GPU work? The CPU isn't stepping down if its working at 30% but if it doesn't happen when the GPU is working then it might not be the PSU unable to deliver power. I'd still check the CPU temperature too and clean out the case if it's dusty.

What's the hardware of your machine anyways? CPU-Z can report that if you're not sure.
No, it doesn't happen at all. I was netplaying Mario Kart Double Dash with a friend of mine last night (Firefox was up with Skype and Dolphin) and running perfectly fine so...

And now for screenies:

Hmm, nothing looks amiss. Not sure what to check next besides generic stuff: Check the RAM with memtest, try scf /scannow again on this machine, and maybe manually settings the RAM voltage and timings in case the motherboard is setting them wrong (which is unlikely but possible, I don't know of it being an issue with Microstar but Gigabyte mobos in the late C2D age had this issue (along with others) )

e: Start with scf /scannow because its easy, memtest because that just needs something to boot off of besides your hard drive, then ram voltages because it can be stressful.
Will give a try. My computer JUST bluescreened a little bit ago (once again, Firefox and Skype are the only things up and it came without warning), so will probably do that before I go to bed or something (or when I first turn the comp on tomorrow since I Never leave comp on when I'm not using it). >_>;
Ok, so I gave scf /scannow a try and it found nothing wrong. Found my flash drive that has my Memtest, will be trying that next. I would like to do this while sleeping, but the problem is this computer is really REALLY loud when on at times, so...more than likely I ain't gonna get any sleep if I leave it on, so will probably have to spend tomorrow letting it do its thing while I do something else. Any suggestions on how long I should let Memtest run for?


So this is what I got. It wouldn't let me choose Memtest from my flash drive (may have to do something else??) but it seemed like it did the same thing (or maybe it is what I was doing after all). So...there's that. this time, the bluescreen was different (this one was while netplaying Mario Kart Double Dash with a bud of mine). This one was an "IRQL_Not_Less_Or_Equal" error. I remember getting these errors a LOT on the previous computer, which I somehow fixed by turning off one of the USB ports or something like (usbihco or something like that???)...but I don't think that's the problem here so...yeah!
Did you use the download for USB drives? It'll format the drive to make it bootable so you can choose it as the boot media when your computer is turning on. Or is that what you tried?
That's what I had on this USB drive. It just didn't select it at all on boot-up when I thought it did (it did the default memory diagnostic thing).