THE OFFICIAL ENGLISH 2K3 VERSION IS OUT!

Posts

Ha, I see what you mean. I wonder if this is just a confusing thing to talk about. That's what me and Pepsi both thought you meant.

Regardless, I'm inclined to agree that "Variable ID" isn't the best way of putting that.

I thought it meant

Set 0001: VarX = Variable ID 0002: VarY
0001: VarX == 2

What it actually means

Set 0003: VarZ = 10
Set 0002: VarY = 3
Set 0001: VarX = Variable ID 0002: VarY (which is 3, so it refers to the value of 0003: VarZ)
VarX == 10

It seems to me what I thought originally is more intuitive. If that's true (maybe it's not) then Variable ID really ought to be called something else.

I could definitely be wrong. Maybe nobody else feels that way.
I can understand why you think that way now, but before Pepsi brought it up I'd never seen an issue with it because it always made sense to me. XD

It's probably not going to change since the whole series is labelled as the same thing (I think?).


Also, wow, you're just on the cusp of something great, BL~
Ugh this is just the worst thing to explain...

author=Liberty
No, what I meant is that I never saw it as not being assigned to the number of the actual variable in question - that is, it is relating to another variable number. The Variable ID is the number of the variable itself - you're picking to show that variable's input. It's a very simple concept to understand. You're basically making one variable INTO another variable - by picking the number of the variable (the ID of the variable) you want to substitute.

You're stealing that variable's 'identity' (ID). Variable 0001 is now (for all intents and purposes) Variable 0003.

You're describing setting a variable to another variable though. That's not what it does. It set's a variable to the value of a variable defined by another variable's value (lol). Just do this in both official and unofficial 2k3:

@>Control Variables: [0007] = 21
@>Control Variables: [0021] = 6
@>Control Variables: [0001] = Variable ID [0007]
@>Text: \V[1]
: : \V[7]

... It's the behavior of an array index, because you're essentially doing this:

a = b[b[7]]
a = b[21]
a = 6

Maybe neither description is intuitive enough.

Edit: Slowbro
It's one of those things that are hard to explain with just text but that is essentially what I said. Or tried to say. It is one variable picking a victim (that is the ID part - the 'name' of victim that they pick), then rifling through the victims pocket and stealing their credit card information, pretending to be them and use their information.
Gretgor
Having gotten my first 4/5, I must now work hard to obtain... my second 4/5.
3330
I have a question: I heard there's a more recent version of RM2K3 Official Release than the one I currently have (1.10a). Is that true? If so, how would I go into updating my RM2K3 install?
Yeah, 1.11 is up. You should be able to download it from the main RMW site if you don't have the steam version (check for the main thread)
Gretgor
Having gotten my first 4/5, I must now work hard to obtain... my second 4/5.
3330
If I go into "My Account", and get the download link contained among my purchases, it just downloads the 1.10a installer again... :(
You might need to wait for the site to finish updating some stuff. There should be an actual thread, though, (do a search for RPG Maker 2003 Updates or something like that) where they have a list of the updates and stuff like that. I'll have a poke around later to see if I can find it if you haven't by then. (Gotta say, I'm not really big on the new site design :/ )
In official RMW forum are 3 things why RMW 1.11 version hasn't yet update.
1. 30 Oct. 15 - Cherry - "As far as I know, a larger maintenance project on the website/store is going on and all updates are being delayed because of that."
2. 15 Dec. 15 - Artemis - "I sent a message to RPG maker facebook page asking the same thing and the answer was:"The files have been sent to our office in Tokyo to have the DRM wrapper placed on it, but we have not received it back yet. We are working on getting this done very soon. We apologize for the delay"
It was a month ago."
3. 25 Dec. 15 - Launder - "I've been told by support, after so many emails asking for real answers, that standalone versions won't get any of the update(s). Yes, it's lame and disrespectful for customers who do not want to go through Steam..."

I already not wait (this is no sense) for NORMAL RM 2k3 1.11 and more version. I think that Degica has in ass RM 2k/3 users - if reason 3 is true.

RM2k/3 is only jailed in sream:


I in last month buy RM95 (normal and value) and I pleased. I finally make game in this, not sream's prison versions.
So you're taking the word of hear-say instead of asking on the forums yourself for an official response? That's rather silly.


I had a look on the official site and couldn't find the topic, but it might be a good idea just to ask there, Gregtor. At least that way you'll be sure to hear official replies instead of hearsay from random people you don't know from squat.
I didn't say nobody asks for it, but that perhaps looking for an official answer instead of someone just saying 'I heard this about this' is best.
Mirak
Stand back. Artist at work. I paint with enthusiasm if not with talent.
8823
I'm definitely glad i bought the steam version, all things considered. :(
Has the method for getting people to play your game without the RTP changed? The brickroad article from years ago doesn't really match (http://rpgmaker.net/tutorials/10/). The FullPackageFlag=1 in the ini isn't even there. I didn't find a harmony dll from the steam rtp folder so I took one from the tsukuru folder and that didn't work.

I'm in the middle of uploading a game for the game jam and I'm kind of in a hurry.
The FullPackageFlag=1 isn't supposed to be there, you have to add it in yourself. The Harmony.dll shouldn't be necessary.
I've been away from the community for some time now... Any word on DynRPG/patch support for English RM2k3?
There doesn't seem to be a great repository of information regarding this patch. There are the patch notes, but they omit many things like planned future features, state of the Steam versus non-Steam version, or use of older patches (like DynRPG). For example, I can't even find a thread that advertises updates to the English version. I think this definitely harms adoption.

Concerning your question, however, I'm fairly certain that there is now support for DynRPG with the English rm2k3. There was apparently some concern with the legality of it (originally it was implemented and then removed or something). I can't remember where I read this, though, and I can't find it on Cherry's website nor in the change logs. Can anyone confirm this?

Speaking of change logs, they can be found here:
https://docs.google.com/document/d/1sXlXZIXdjxVq5gh_lPFuFLMbMRzZe4BKPpRI13ZD2Qc/edit?pref=2&pli=1

The change logs are updated as new versions are released and are quite extensive. Really it's amazing the amount of work and care that has been put into making the English version.

EDIT:
I guess I could link the DynRPG website here and the offical English support topic too.
http://rpg-maker.cherrytree.at/dynrpg/
http://rpgmaker.net/forums/topics/10254/