[RM2K3] SUDDENLY...GAME KEEPS CRASHING?

Posts

Pages: 1
Ok, ok. I know, I've made a lot of these topics recently, but this one is...perplexing. You see, lately I've been having that weird issue of getting game overs after defeat handlers again, which was an issue long, long ago (I forgot how I solved it). This time though...I'm honestly perplexed. First, I figured it was my Disable coding, because removing that from all events kept the game from game overing (why changing battle commands would cause that is beyond me). However, I also found out that in one of my Battle Cleanup events, having Reimu remove all statuses from herself after battle (note that Battle Cleanup events are triggered at the start of fights, and will run through after every battle only once due to them using switches) apparently ALSO causes this. What's bizarre is this never was the case before. It always worked perfectly fine. So what gives now? Why is the coding suddenly causing the game to game over after Defeat handlers?

To make matters worse, sometimes when it game overs it...either black screens or takes a lengthy amount of time for the Game Over screen to even appear...


EDIT - Ok, I'm a serious loss here. I may need someone to help look this over with me and see if anything can't be done to fix this up because...I am not understanding why this is suddenly broken. First the Disable, now anything that removes statuses including Death, and it seems like even changing skills does this. I don't understand why when it never broke the game before??



EDIT #2 - Ok, after a LOT of bloody testing for too long, I've found out that, for whatever reason, it A) Doesn't like statuses being removed at ALL (meaning I can't use Change Character Condition), B) Doesn't like battle commands being added/removed at ALL (however, it's fine if it's DURING battle for some reason...it just doesn't like it AFTER battle...), and C) Doesn't like skills being added/removed at ALL. Again, this has NEVER been a problem before, and I honesty don't know why it is. For reference, here's some screenshots of the coding right now and the way it was before:

Before:




After:







Before:

Hm, as far as I know, there are several places in the code where the RM checks for a game over condition such as "all dead". This can be triggered by various things. Make sure you first revive at least 1 character before you start doing anything else such as adding/removing skills or whatever.
Yeah, I added in a revive right at the start of the Defeat handler and that fixed things up. It's weird though, why would it suddenly do that out of nowhere after months of not doing that?? It seems to do that whenever statuses, skills, or battle commands are added/removed at all. @_@;
It's done that all the time - I also had an issue where sometimes it would work and sometimes it wouldn't. Fixed it with a revive just after the battle was ended and it's worked fine every since. Not sure what caused it but it was there in the 1.8 and 1.9 versions. You might have just gotten lucky that it didn't trigger on you for all that time. >.<;
I guess. I know that when it was happening when I was testing what was wrong, sometimes it would game over like a few seconds into a dialogue box being open (with it either being a black screen or very very slowly getting to the game over screen), or immediately game over after closing the first dialogue box (same thing with the game over screen as before). I searched this site for this issue and found an old topic of mine from 2 years ago where I had this issue too (back when I was trying to fix my HP/MP+% stuff) where the HP+% stuff would make the game just game over after Defeat Handlers even WITH the revive (which I can understand, that's dealing with HP), but it's still really REALLY bizarre that those 3 things alone would cause that.

What's even MORE bizarre is that my beta tester never had this happen to him at all, nor has anyone reported this as an issue to me all this time. @_@;
As far as I remember, all hero-accessing events just call the "Check Game Over" function at the end, "to be sure" probably. I do understand it for status, party and HP modifications, though.
Got it. So here's another weird....issue going on that I've no idea what's going on and it's happening only at this point in the game (untested territory but still). So, normally when you attack and put in any other input, the game waits until the current action is done before it does any other action, right? However...for some reason in this dungeon, whenever any input is put in, it'll interrupt whoever is currently taking the action (bar enemies) and they'll just...be stuck in whatever spot they're at until their next turn (meaning their turn gets wasted). I don't know WHAT'S causing this or what's going on, but...anyone have any idea what it is?
So I resolved this issue, which is...another bizarre case. So, apparently if you have a Change Condition in the Turns Elapsed x1 event, it'll produce the issue I was having where any action will cancel out the current action being taken by a character, including enemies taking actions. I...don't know why this interrupts actions especially when it's not a action stalling thing like Paralysis or anything, but yeah...
Do you like bugs? I love bugs, especially when it's more errors involving scripts that don't exist, whether it's a teleport event or an event that you have to step on. And apparently, this is something in my Battle Event that...never caused this issue before. I'm honestly confused as to what this is. Cherry, would it be possible for you to get my game (and the file that I am using) to see what is causing this bug? Because I'm pretty sure at this point something is really, really bugging up that shouldn't be...




A person reported this to me today. Once again, me and my beta tester did NOT have any issues with this before, and it seems to be related to the same thing that was causing the issue with the game overs kicking in after Defeat Handlers. I don't understand why this one Common Event is causing so much trouble recently...



EDIT #2 - Ok, this is downright confusing. So if I do nothing, the game will crash whether I try to leave through a teleporter to the world map, if I try to step on any spot near the save point (which are events that turn off the PHS/Tent/Forbids Save Menu), or during the next cutscene when an emoticon is supposed to appear (governed by a variable). However, I tested something by putting in a character sprite right after the cutscene, with the message box of "A" and making an emoticon come on. This...somehow fixes it and I don't know why??



EDIT #3 - Still trying to figure this out, and being even MORE confused by this. I don't even know if it's the Kraken fight that's causing issues (whenever I remove Start Battle Events, everything's fine. If I remove the Battle Cleanup Switch, everything's also fine IIRC. But turning the battle cleanup common events off doesn't fix it??) or if it's something else going on (note: that area in the screenshot is 2 screens over from where the last cutscene is played from. All save points act this way, as do all teleport events that go to the world map. I can use shops just fine and dandy it seems, and I can still go into the menu and use skills but...I don't know! I'm lost and I need someone to help out with this. Otherwise, I'm going to be quite stuck). Once again, it's ONLY in this one area and it doesn't make any sense as to WHY it's doing it now...
It really sounds like there is some event running across a map and accessing an old map's event on the new map.

What you could also do to help me understand the issue is this: http://rpgmaker.net/forums/topics/18789/?post=676047#post676047
Sent the dump file to you via PM. I leave it in your hands, as I'm at a loss now...
It's caused by a patch. It smells to me like something by bugmenot (it's his typical address area) and I'd guess it's AntiLagSwitch or AntiLagSwitch(Slow) or something like that because the callstack of System::RaiseExcept looks like this:

004AB88D GetEventAbsolute+59
004AC2D9 GetEvent+69
00446DF9 ? (patch)
00446DE1 ? (patch)
004ACB14 ProcChangeSwitch+D4
...and directly before the last location there is a call to UpdateEvents (004AB8B4), but inside UpdateEvents there is a jump to 0046DA5 (inside the patch) patched at address 004AB8BB.

This leads me to believe it has something to do with an AntiLag patch (or maybe another patch which is now in conflict with this one).

Sorry, I can't help you more than that, you would have to contact bugmenot.

(I was unable to find out which event ID was requested because this value is never pushed on the stack as far as I can see, and the registers its in are also overwritten before the exception is thrown.)

EDIT: The error happens during a "Change Switch" call which normally also updates the event page start conditions, on line 2 of event #7 (sorry I don't know the page ID), map #146 (hero standing on tile 026/005).
Hmm...I'll try removing that patch then and see if that works. That is odd though.




That's what's in that event. Which is the PHS switch of all things. Hm...



EDIT - Yeah, seems removing the AntiLag (Slow) plugin fixed that. That is so weird though that it ONLY affected that part of the game and nowhere else. Wonder why that is when other events are exactly like that. Huh...much obliged for the help Cherry, I wouldn't have even thought it would be a plugin!

I'll also note this in the DynRPG Plugin topic so that they know there as well, and see if anyone else gets any other issues as well.
Pages: 1