Pages: 1
I'm using a computer that is running Windows XP. No one is using this operating system any longer.

This was made all the more apparent to me when I bought and then tried to register RPG Maker VX Ace. VX Ace uses a built-in Internet Explorer browser to access RPG Maker's registration/DRM server and verify itself. However, due to the updating of all websites' security protocols over the last year or two (including rpgmakerweb.com), Internet Explorer-based browsers can no longer access these websites.

I contacted tech support. This problem is allegedly solved by switching to TLS 1.2 (a security protocol parser?) in Internet Explorer's Advanced Options settings, but Windows XP is so old (can't believe I'm typing that), that no such option exists. I'm stuck on TLS 1.0.

I'm assuming that tech support has abandoned me, as I have not heard back from them for two days. Should I just ask for a refund at this point? If that's even possible. Or can they still do something? There is an Offline Manual Unlock option on the registration page when you open the program.
I don't want to pry into your financial/general life situation but are you absolutely stuck using this computer? I can't imagine Ace is going to run terribly well on a nearly two decade old operating system even if you can get your copy verified.

I would say try installing Steam and activating the product there but goodness knows if Steam can run on XP anymore, either.
It's true: Every VX Ace game that I've downloaded to this computer has had running problems. It's tempting to get a new computer, but I'm trying to get a better job first... can't afford the $300-$500 cost now.

I'm buying VX Ace for the RGSS3 Ruby 1.9 upgrade, to see how it compares to RPG Maker XP's Ruby. I tend to code my games from the ground up, and the simple structures I build for them seem to have no problem running at 60 fps in XP.

Back to the topic, you're right on the Steam point too: Steam stopped supporting XP around January. Maybe I could still download something, but I don't know.

Googling "TLS 1.2 windows xp" turns up some scary options, like permanently modifying the windows registry, then installing a microsoft update as a bodge to get TLS 1.2 working... Want to hold off on potentially sacrificing this computer until I can get a more definitive judgment from tech support.


The support team worked their magic and gave me a code to activate my copy remotely. :)

I can only hope that the next time I need to do this, I will have an operating system at least as old as Windows 7.
Pages: 1