Pages: 1

Some reports have been sent recently regarding the way Windows 10 handles video in Aedemphia. The game starts normally, the bug only occurs when playing the video. This normally works with MPEG2 codec. The game works fine on former OS, it's only with Windows 10.

The bug is graphical : when the video starts, the screen turns black but the sound works (meaning that the video is playing).

Details of what we found so far :
- the bug occurs either it's the ancient version of RM2003 (1.08) or the new one (1.12)
- the video is showing normally when transferred from PC to TV, with certain parameters : when above 1080p, Windows sends a YCbCr 420 signal instead of RGB. When it's the case, the video shows. The video are encoded in YCbCr 240.
- this bug doesn't occur on all windows. With the same options on RM and same codecs (we checked), it works for some but not other (it's working fine on my computer, which has mimnimal graphical settings, but not on his, which is all new)
- When FFDShow is installed, the video shows correctly first, but then when launched another time, the screen turns black.
- Without the codec, the video can't be read (logical).

Since then, the dev has installed different codecs, with no effect. He also tried to install DirectDraw older options with a Windows tool, but it didn't work.
So far, settings are :

Video codecs installed (we have exactly the same, so I don't think it's that) :
ICM Codec Cinepak de Radius cvid iccvid.dll
ICM Codec Intel IYUV IYUV iyuv_32.dll 10.0.18362.1
ICM Microsoft RLE MRLE msrle32.dll 10.0.18362.1
ICM Microsoft Vidéo 1 MSVC msvidc32.dll 10.0.18362.1
ICM Microsoft YUV UYVY msyuv.dll 10.0.18362.1
ICM Toshiba YUV Codec Y411 tsbyuv.dll 10.0.18362.1
ICM Microsoft YUV UYVY msyuv.dll 10.0.18362.1
DMO Mpeg4s Decoder DMO mp4s, MP4S, m4s2, M4S2, MP4V, mp4v, XVID, xvid, DIVX, DX50 mp4sdecd.dll 10.0.18362.1
DMO WMV Screen decoder DMO MSS1, MSS2 wmvsdecd.dll 10.0.18362.1
DMO WMVideo Decoder DMO WMV1, WMV2, WMV3, WMVA, WVC1, WMVP, WVP2, VC1S wmvdecod.dll 10.0.18362.1
DMO Mpeg43 Decoder DMO mp43, MP43 mp43decd.dll 10.0.18362.1
DMO Mpeg4 Decoder DMO MPG4, mpg4, mp42, MP42 mpg4decd.dll 10.0.18362.1

If you are on Windows 10 and would like to help, here is a small game with a video included : http://www.aedemphia-rpg.net/divers/Test.7z
And here is the codec : http://www.aedemphia-rpg.net/download/mpeg-2_codec.zip

If you have any ideas of what it could be, it would greatly help figure out a solution for the project ! Thanks
Hi and happy new year,

Sorry to come back, but the problem hasn't been solved. And we had some news.

In fact, it's even worse: every people testing the game has a different kind of problem: the developper can play the game with no bug by connecting the tv to his computer, but it doesn't work at all on computer.
Someone made other videos with different compressions, to test if that solved the problem :
- https://www.mediafire.com/file/ze2u8zcc92bkzwe/Test_Ae_plusieurs_formats.zip/file (AVI Codec H264 ; AVI Cinemax ; MPEG1)
- https://www.mediafire.com/file/45ltomxfa3if4x3/AE_Test_WMV.zip/file (WMV 7 & 9 : normally can't be read by RM, but you can lure it by changing extension)
So far, it didn't work for some but it did for others, it's really varying. Most of the time, the video works once but not twice (only a black screen with the sounds). I'm the only one for who everything is working so far, whether the game is fullscreen/windowed, played twice, etc. But I can't explain why (we have the same configuration, only graphic cards change).

We don't really know what to look for...
RM2k(3) uses DirectShow for the movie playback - a media control is positioned at the same place where the game canvas is, the filter graph manager is asked to load the video and the media control is set to run. Once it receives either a "completed" or an "error" event, it removes the media control and continues game execution.

I had one idea, that maybe some subtle difference in modern Windows versions causes the video canvas to be rendered below the game canvas in some circumstances so it can't be seen, but that doesn't seem to be the case because I tested hiding the window mid-video and then you just see the regular game screen, not a black screen.

So I don't know either what can cause this.

By the way I tested all the videos in the first link and they all worked for me fine, also multiple times. (However Cinemax was laggy and jittery for some reason.) I have the K-Lite Codec Pack installed, and according to my systray icons it seems that the "LAV Video Decoder" gets used to decode these.
Most of the time, the video works once but not twice (only a black screen with the sounds). I'm the only one for who everything is working so far, whether the game is fullscreen/windowed, played twice, etc. But I can't explain why (we have the same configuration, only graphic cards change).

We don't really know what to look for...

Thanks for replying Cherry, I wasn't here of June last year, so I missed this thread. But I was going to ask you about this very same issue this year. I mostly use mpeg-1 muxed and CinePak AVI for all my video files in rpgmaker2003, because I was told that these offer the most compatibility without having to install additional video codecs to make video files viewable in rpgmaker2003. (they even work on mac os if you use old winewrappers)

But yes, in let's play streams of games I've made. rpgmaker2003 will only play the video file once. If it tries to play it again, a blackscreen will show and only the audio in the video will play.

Back in 2018, I created a small demo to help sort out this issue. But I can't seem to recreate the problem on my own machine Windows 7 machine. I've only seen it on other people's playthrough videos on youtube. The demo is available below. How I converted video files to MPEG1 mux and CinePak AVI are available through this thread.
Anyone with Windows 8 or Windows 10 Please download this quick demo:-


1.)Record your playthrough with OBS
2.)Talk to the Cat in the demo.
3.)If rpgmaker2003 can play the video back 4 times, rpgmaker2003 video works.
4.)If the video doesn't play 4 times, report your findings and upload your playthrough/video here.

If played successfully, this is what the demo should look like, while playing in RM2k3's window mode:

Any feedback here is very much appreciated.

Please keep us updated on this issue Cherry! I was gonna create more games this year that use video files, but if a solution isn't found, I'll probably just stick to using one video in rpgmaker2003 at a time, in order to ensure optimal playback.
Pages: 1