Pages: 1
So ever since trying to replace a system set I now get the message "Unsupported PNG type" or "file" (can't remember which). However this is not due to there actually being an unsupported .png file there. Firstly because I got the colour depth right to begin with and that would have snagged upon import. I've tried renaming the file etc. I've made multiple versions.

ALSO I can't even use any of the system sets, including the RTP ones, anymore without it giving the same error message upon startup or test play. The game seems to be buggered basically. Does anyone have any idea how to fix this? Or an easy way around it?

This is RM2k3, by the way.

Also somehow this problem reappears when attempting to copy the project over to a new project.

Also have tried using Cherry's RM Ultimate 2009.

This is really shitty, anyone have a clue?
Perhaps you have another image with the wrong color depth lying around in one of your game's folders and that's what's prompting the error? Because I've never heard of anything like this before and it doesn't quite makes sense for it to be a bug either. If the maker says a Png file is the cause then a Png file must have been saved incorrectly.

Also, why use the import tool when you can just copy/paste files using Window's explorer? xP
So I made a copy of the project and deleted every single resource from it. Then attempted to play it and it asked for the system set (system set blah is missing). So I went to the databased and changed it to the RTP system set and now it still gives the same error message.
(Socrates would certainly not contadict me!)
Im a total noob, but there are 2 systems in rm2k3, which are quite different graphically, did you import your new system in the right one? an idea...
I've managed to salvage enough of the project for this to not be too much of a problem now.

Thanks for the replies though guys. Seems my project database file had somehow corrupted or something like that. I had to copy another database file over and reassign everything in the db, luckily I didn't have too much in there yet (as it was a new project). I managed to salvage my mapping and events though.
It is also possible you inadvertently editted the RTP, but it sounds like yoy fixed it. Strange though, because that is an engine error and not a database one.
Pages: 1