Pages: first 12 next last
A new Plugin has appeared!
This time it's a plugin which is able to add additive and subtractive blending modes to your pictures. This is simply done by adding .add, .sub, .mul or .ml2 before .png in the filenames of your pictures.

Some examples:

No blend mode, 50% transparency (for comparison)

Additive Blend Mode

Subtractive Blend Mode (+ additive ghost)

Multiplicative Blend mode

2x Multiplicative Blend mode

And here's the download. It includes a tiny test project which you can play around with in your rm2k3 editor.
I have a list of Plugins I'd like to write.
It isn't short.
Developer, Starless Umbra / Heroes of Umbra
LE's with ease! This is cool. :)

Fixed a tiny bug which made you unable to replace picture by show picture alone (i.e. had to call erase picture first).
Also, added multiplicative and 2x multiplicative modes.
Lot of thanks to Kyuu from rpg atelier who has helped me with the blending algorithms
You should submit this to the site!
Ah, right. I can get makerscore for these. And they've even been made more visible since the last update. Cool stuff
Amazing! I was waiting a plugin like this for graphics! thanks

I founded 2 bugs:

1 - If I change "fyr.sub.png" to 640x480 it give me this error

this error ocurr with the others filters too
It seems that "fyr.add.png" works fine at 640x480

2 - If in the same event I use 2 pictures, one with some filter, and other one in other number with no filter, it showed with the filter of another image of other picture, no having any .add or .sub etc added

Example: The image 3 will be showed in the game with the "add" of the image 2

The bug with too big pictures has been fixed now. I had actually already fixed it (which is why .add was working) I just forgot to apply the fix to the other modes as well. As for the second, not sure what's happening there. I tried to recreate your problem, but when I add another picture like that, my picture shows without any blend.
Oh cool! Now it works fine and I don't see anything strange as the second bug as I said
I'm not really sure of this but if in a map you use any additive blender with some picture, the transparency of others events of the same map don't work

Just did some minor tests, and could not recreate it. If there is a bug with it, I wouldn't know where to look, since I'm not touching any event data at all, just Picture data.
Developer, Starless Umbra / Heroes of Umbra
I believe transparency issues are a bug with DynRPG itself. (There was a post about this in the official thread I believe.) Kazesui are transparent events working for you?

This seemed to crash for me when I called my custom message system (essentially pictures) while an additive-blended image was displayed. However, this was the older version and I'm hoping the new one fixed this.
Yeah I tested it and it seems a main dynrpg bug
Hi, I have other rare bug
When you use some pictures and add in a cycle or label for make a animation, and test the game it give a error message, and it goes to the title screen, if you retry play it works fine. strange bug!
(and no using any blending picture)

Even newspapers have those nowadays.
Could you add Alpha blend mode? So we can make normal picture and over it (higher ID) grayscale one with alpha mask?

E.g. picture #1 is normal picture and picture #2 is alpha mask for picture #1.
Not quite sure what is causing that bug yet, sorry, but will try to figure it out.

@alpha channel, haven't had time to look closely enough at the algorithm for it yet, and have other stuff to do as well, so you have to wait a while before it's implemented (if).
Algorithm the RPG Maker uses for transparency:

R = R (picture) * (alpha + 1) + R (screen) * (256 - alpha)
Same for G and B

If you do this, you could store the second image in the image2 buffer of the RPG::Picture after calling merge(). Set the transparency2 to 100 to prevent the second image from being drawn.
Can I put here some lights I did? So if someone wanna try the plugin, you
can use anyone Kazesui if you upload any example or that what you want using em:p
This pictures looks amazing, but imageshack rename the images without ".add"

in-game its looks very cool
Pretty good plugin. I had to delete it though.

Known bug: I had an opening with some serious picture and text usage, and then a battle (with a common event that tinted the screen dark, and then caused it to rain during battle). This battle literally froze and wouldn't play. I seriously doubt all of you will have this happen, but since I couldn't get the battle to load at all, you may want to look into it.
Pages: first 12 next last